Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Разделитель времени

Автор Самадова Камилат, 22.03.2013, 01:56

« назад - далее »

Самадова Камилат

Здравствуйте. Нужна помощь, можно ли Excel вводить числа, чтобы автоматически вставлялись разделители, когда я имею дело с форматом времени hh:mm?

DV68


zs

формулой можно преобразовать, если ДЛСТР=4, = два левых&:&два правых знака

edmar07

Цитата: zs от 22.03.2013, 14:12
формулой можно преобразовать, если ДЛСТР=4, = два левых&:&два правых знака

а как это в формуле =если( ДЛСТР(A1)=4; два левых&:&два правых знака;)?

cheshiki1

edmar07 =ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);"")

Михаил С.

#5
В А1 время в формате 0232, в другой ячейке формула =ЗАМЕНИТЬ(A1;3;0;":"), получим 02:32; если эти часы потом  нужны для расчета, то =--ЗАМЕНИТЬ(A1;3;0;":")формат ячейки - время.

UP.
В общем случае =--ЗАМЕНИТЬ(A1;ДЛСТР(A1)-1;0;":")
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

zs

=ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);"")>=--ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);A1)

Самадова Камилат

Я вообще ничего не понимаю, куда надо вставлять "=ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);"")>=--ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);A1)". Мне нужно составить реестр, с указанием времени. Например я пишу 2230, а нужно чтобы он автоматом ставил разделитель 22:30.

DV68

Если Вас не устраивает макрос, ссылку на который я давал, то в параметрах автозамены замените "++" на ":".
Тогда время будете вводить так 22++30
У меня так сделано и мне удобно, ввод на правой цифровой клавиатуре одной рукой.

zs

Цитата: Самадова Камилат от 22.03.2013, 22:45
Я вообще ничего не понимаю, куда надо вставлять "=ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);"")>=--ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);A1)". Мне нужно составить реестр, с указанием времени. Например я пишу 2230, а нужно чтобы он автоматом ставил разделитель 22:30.
"=ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);"")лучше=--ЕСЛИ(ДЛСТР(A1)=4;ЛЕВСИМВ(A1;2)&":"&ПРАВСИМВ(A1;2);A1)"
вам лучше воспользоваться макросом :)