Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Какой формулой из ячейки А1 скопировать первых три слова?

Автор wwizard, 26.03.2013, 20:22

« назад - далее »

wwizard

Какой формулой из ячейки А1 скопировать первых три слова?
слова отличаются по пробелам, но не далее запятой в тексте ячейки?

Вот пример, копировать три слова надо в столбец
Желтым цветом помечена ячейка где стоит запятая после второго слова, т.е. при везде копировании трех слов, в столбец , в ячейке [B3] должно появится только два слова.

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

zs

скопировать до 1 запятой или скопировать до 3 пробела

zs

=ЕСЛИ(ЕОШ(НАЙТИ(",";ЛЕВСИМВ(C4;НАЙТИ(4;ПОДСТАВИТЬ(C4;" ";4;3)))));ЛЕВСИМВ(C4;НАЙТИ(4;ПОДСТАВИТЬ(C4;" ";4;3)));ЛЕВСИМВ(C3;НАЙТИ(",";C3)-1)) Формула на 4 ;)