Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Функции ВПР и СЦЕПИТЬ

Автор Extra, 03.04.2013, 17:36

« назад - далее »

Extra

Вопрос: Есть ячейки с Фамилией и Именем, необходимо найти данный текст в другом массиве с Фамилией Именем и Отчеством, и вернуть значение Фамилия Имя Отчество. Какую формулу с текстовыми функциями можно применить?

cheshiki1

ВПР по идее должно подойти. Более точно при наличии примера.
п.с. кто вам сказал что ВПР текстовая ф-ция.

Extra

Пример вложен.

Хотелось бы увидеть формулу, ВПР подходит, но необходимо использование еще текстовых функций, каких и в каком виде, вот вопрос.

cheshiki1

=ВПР(СЦЕПИТЬ(B2;"*");FullName!$B$2:$B$1110;1;0)
применена текстовая ф-ция "СЦЕПИТЬ(B2;"*")" её можно записать по другому B2&"*"

Extra