Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Как заменить идентификаторы реальными названиями?

Автор Наталя Священко, 03.04.2013, 17:56

« назад - далее »

Наталя Священко

Есть таблица - идентификатор, название. И есть вторая в которой тот же идентификатор и куча колонок с данными, в первой колонке идентификаторы могут повторятся. Как во второй таблице заменить или добавить названия этих идентификаторов выбирая их на основе первой таблицы?

Wasilic

#1
Цитата: Наталя Священко от 03.04.2013, 17:56
Есть таблица - идентификатор, название. И есть вторая
А, у кого они есть? :-\
Имеется ввиду - п.2 правил_форума.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

Наталя Священко

Извините, первый раз на этом форуме.
Вот файл с примером.
Нужно на листе 1 заменить данные колонки ID именами с листа 2 которые соответствуют этим ID.

cheshiki1

если заменить то макросом.
если без замены в отдельном столбце то вариант:  в F2 вставляем и растягиваем.
=ВПР(A2;Лист2!$A$1:$B$5;2;0)

Наталя Священко

Спасибо, помогли. Воспользовалась вторым способом.