Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Подсчет по сложному условию

Автор Ppaa, 07.04.2013, 01:52

« назад - далее »

Ppaa

Имеется пример столбцов с датами и временем.

Нужно подсчитать количество заданий, для которых поле «Запрошенное время дня для визита» пусто и время от значения поля «Дата создания задания» до минимального из значений полей «Время закрытия наряда» и «Дата первой авторизации» превышает для «ГТС» 48 часов, для «СТС» 120 часов.

У меня пока получилось сделать это только через добавление дополнительного расчетного столбца. (см. вложение) Можно ли все значения указать непосредственно в формуле?

Заранее благодарен.

DV68

1. Ваша формула считает неправильно, т.к.
сутки = 1, соответственно 48 часов в Excel = 2, а 120 часов = 5.
т.е. должно быть ">2" и ">5" соответственно
2. Формула такая:
=СУММПРОИЗВ((D2:D5000="")*(ABS(B2:B5000-ЕСЛИ(Ч(C2:C5000)<Ч(E2:E5000);C2:C5000;E2:E5000))>ЕСЛИ(A2:A5000="ГТС";2;5)))

Ppaa

=СЧЁТЕСЛИМН(D:D;"";A:A;"ГТС";G:G;">48")+СЧЁТЕСЛИМН(D:D;"";A:A;"СТС";G:G;">120")
Ну почему же неправильно, результат вычислений тот же - 11. и если в вашей формуле сменить 2 и 5 на 48 и 120, то результат получается тот же.
Но все равно спасибо!


DV68

#3
Хозяин-барин
Вообще-то моя формула в Н5 выдает 12, т.к. считает ячейку G14. Вам 48 часов или 48 дней надо??

seregaad

#4
Помогите, уже голову сломал, понимаю, что просто где-то туплю, но ни как не могу понять где...

Нужно подсчитать количество значений в столбце D, если значение в столбце C = значению в ячейке F12

cheshiki1


seregaad

Цитата: cheshiki1 от 10.04.2013, 15:48
=СУММЕСЛИ(C12:C21;F12;D12:D21)

Будет выдавать "0" т.к. в столбце D не цифры, а текст и цифры в вперемешку.

Serge 007

А если попробовать, прежде чем писать?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

seregaad

Цитата: Serge 007 от 10.04.2013, 18:07
А если попробовать, прежде чем писать?


Согласен, но результат не верный, должно получиться в вашем примере "абв" - 4, т.к. нужно количество значений в первом столбце "А" по абв , а не сумма чисел.

Serge 007

Цитата: seregaad от 10.04.2013, 18:30
нужно количество значений в первом столбце "А" по абв , а не сумма чисел.
Кому нужно?
Функция СУММЕСЛИ в принципе не считает количество, она суммирует числовые значения, игнорируя значения текстовые. Я лишь указал на ошибочность Вашего заявления о том что
Цитата: seregaad от 10.04.2013, 18:01
=СУММЕСЛИ(C12:C21;F12;D12:D21) Будет выдавать "0" т.к. в столбце D не цифры, а текст и цифры в вперемешку.
Если ВАМ нужно количество числовых значений, среди всех значений, по условию в другом столбце, то используйте такую формулу: =СУММПРОИЗВ((B1:B6="абв")*ЕЧИСЛО(A1:A6))


Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

seregaad

Цитата: Serge 007 от 10.04.2013, 18:42
Цитата: seregaad от 10.04.2013, 18:30
нужно количество значений в первом столбце "А" по абв , а не сумма чисел.
Кому нужно?
Функция СУММЕСЛИ в принципе не считает количество, она суммирует числовые значения, игнорируя значения текстовые. Я лишь указал на ошибочность Вашего заявления о том что
Цитата: seregaad от 10.04.2013, 18:01
=СУММЕСЛИ(C12:C21;F12;D12:D21) Будет выдавать "0" т.к. в столбце D не цифры, а текст и цифры в вперемешку.
Если ВАМ нужно количество числовых значений, среди всех значений, по условию в другом столбце, то используйте такую формулу: =СУММПРОИЗВ((B1:B6="абв")*ЕЧИСЛО(A1:A6))
Помогите, уже голову сломал, понимаю, что просто где-то туплю, но ни как не могу понять где...

Нужно подсчитать количество значений в столбце D, если значение в столбце C = значению в ячейке F12

Читайте внимательно вопросы....

Serge 007

Цитата: Serge 007 от 10.04.2013, 18:42
...где-то туплю, но ни как не могу понять где...
Подскажу: На форуме
Что бы не тупить - необходимо создавать СВОИ темы со СВОИМИ вопросами, а не лезть в чужие

Цитата: seregaad от 11.04.2013, 08:56Нужно подсчитать количество значений в столбце D, если значение в столбце C = значению в ячейке F12
Если всех значений, то (на моём файле, т.к. Вы не соблаговолили приложить свой) =СУММПРОИЗВ((B1:B6="абв")*(A1:A6<>"")) для числовых формулу я приводил выше

Цитата: seregaad от 11.04.2013, 08:56Читайте внимательно вопросы....
Есть такая русская народная поговорка: "Не учи отца и баста"
Так что: Читайте внимательно ответы
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

cheshiki1

распишите подробно что нужно брать из столбца D если значение в столбце C = значению в ячейке F12
1. к-во чисел?
2. к-во текстовых значений?
3. к-во всех значений (и чисел и текста).

zs

=СЧЁТЕСЛИМН(B1:B11;"*")+СЧЁТЕСЛИМН(B1:B11;">=0") TOLERANTIA

seregaad

Цитата: cheshiki1 от 11.04.2013, 09:51
распишите подробно что нужно брать из столбца D если значение в столбце C = значению в ячейке F12
1. к-во чисел?
2. к-во текстовых значений?
3. к-во всех значений (и чисел и текста).

3. к-во всех значений (и чисел и текста).