Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Подстановка даты

Автор edmar07, 09.04.2013, 20:58

« назад - далее »

edmar07

Добрый вечер

помогите с макросом

нужно в ячейки с форматом времени подставить дату указанную в ячейке В1

файл прилагаю, там есть макрос который это делает по вводу в каждую ячейку (спасибо _Boroda_)
вот хотелось бы по его примеру
- если в ячейке слева время больше, то +1 день
- но сразу нужно учесть  для столбца В, F, J слева тоже могут быть значения (если это не учитывать, то он прибавляет день в столбец В, F, J а это не нужно)

спасибо!

0mega

не уверен, что правильно понял вопрос...
как понял - так и отвечаю:
=ЕСЛИ(B8;(B8>C8)+$B$1;"")

edmar07

Цитата: 0mega от 11.04.2013, 08:05
не уверен, что правильно понял вопрос...
как понял - так и отвечаю:
=ЕСЛИ(B8;(B8>C8)+$B$1;"")

Ну вобщем неправильно ((

время в ячейках уже введено!!! и теперь к нему нужно добавить указанную дату в указанный диапазон!!
но спасибо за попытку )))

RAN

Цитата: edmar07 от 09.04.2013, 20:58
файл прилагаю, там есть макрос

Там нет макроса, и быть не может.

edmar07

Цитата: RAN от 11.04.2013, 14:45
Цитата: edmar07 от 09.04.2013, 20:58
файл прилагаю, там есть макрос

Там нет макроса, и быть не может.

)))

макрос вставлен как текст в автофигуру ниже на странице )))

RAN

И не работает? Странно.  :o

edmar07

Цитата: RAN от 11.04.2013, 19:03
И не работает? Странно.  :o
макрос рабочий, но он работает по вводу, а мне нужно заменять диапазон!!!

edmar07

Эх!!
ну может хоть кто-то поможет!?!? ((

zs


Poltava

Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

edmar07