Заполнить столбец

Автор Вадя, 22.04.2013, 22:02

« назад - далее »

Вадя

Добрый день!
Помогите решить проблему.
Во вложении файл с данными. На вкладке "Значения" данные уникальных городов. Трудность состоит в том, что нужно заполнить на вкладке "Данные" данными с вкладки "Значения" только уникальные города, повторяющиеся города оставить пустыми.

ShAM

Вы бы показали в файле, что должно получиться. А то не понятно, что заполнять, что не заполнять?

Вадя

На вкладке данные значения заполнить только 1-му уникальному городу, остальные оставить пустыми.
Например:
Киев - 5
Киев
Киев
Донецк-3
Донецк
....

ShAM


Вадя

Логика верна, но когда я хочу протянуть формулу вниз, заполняются все ячейки. А как заполнить только уникальные? Нет формулы попроще?

ShAM

ЦитироватьЛогика верна, но когда я хочу протянуть формулу вниз, заполняются все ячейки. А как заполнить только уникальные?
А что у меня не так? Вроде, протягивается. Или Вы думаете, что я формулу отдельно в каждую ячейку забивал? :)

ЦитироватьНет формулы попроще?
Есть. Не массивная.
=ЕСЛИ(СЧЁТЕСЛИ(A$1:A1;A1)=1;ВПР(A1;Значение!$A$1:$B$8;2;);"")
В ячейку В1 и тяните вниз.

Вадя

Огромное спасибо!
Эта формула более понятная, все получилось :)