Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Функция ЕСЛИ - 2 условия 4 значения

Автор Диана Файчак, 06.05.2013, 15:20

« назад - далее »

Диана Файчак

 :-\ Прошу просвятить на тему верного написания формулы с функцией ЕСЛИ, которая опирается на "проверку" двух условий, и имеет 4 варианта значений.

NooBasTiK

#1
Если у вас старый excel (2003) то там только до 7 или 8 раз если можно использовать, а для упрощения используйте формулы И и ИЛИ.

cheshiki1

чуток перемудрили  :)
=ЕСЛИ(E4>=B3;ЕСЛИ(E5>=B3;B8;D8);ЕСЛИ(E5>B3;C8;E8))

MCH

Для разнообразия:
=ВЫБОР((E4<=B3)+(E5<=B3)*2+1;B8;C8;D8;E8)

Диана Файчак

Цитата: cheshiki1 от 06.05.2013, 17:26
чуток перемудрили  :)
=ЕСЛИ(E4>=B3;ЕСЛИ(E5>=B3;B8;D8);ЕСЛИ(E5>B3;C8;E8))
Спасибо!!! С самим принципом построения формулы ещё разбираться буду, а то что работает так как нннадо уже проверила))))