Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Консолидация данных

Автор Andre Mir, 07.05.2013, 15:54

« назад - далее »

Andre Mir

Прошу помочь с консолидацией данных...
имеется 2 листа - 1) Просчет 2) Счет-фактура
нужно с листа №1 взять только заполненные данные столбца С и вставить в лист №2 всю строку

т.е. если Просчет!С9 - не "пусто", то всю 9тую строку перенести в 16тую Счет-фактура! и тд...

Poltava

Решение с доп столбцом но без макросов. В принципе ничего оригинально просто немного переделанный пример отсюдова Выпадающий список с удалением использованных элементов
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Andre Mir

#2
Спасибо БОЛЬШОЕ золотой человек=) :)

а можно еще вопросик?? можно еще сделать скидку вводимую вручную, помимо той которая зависит от объема товара.

т.е. создать поле, которое если пустое, то действует фиксированная скидка, если вводишь свою цифру - то действует та что ввел.
ИЛИ все это организовать в одном поле
т.е. если изменил то действует та что изменил, если не трогал, то программа сама выставляет скидку...
заранее спасибо)

cheshiki1

например А1 выделим под скидку, тогда формула
=ЕСЛИ(A1="";текущая формула;формула с А1)