выборка каждой 10 строки и столбца

Автор Роман Мусаев, 13.05.2013, 09:35

« назад - далее »

Роман Мусаев

Доброе утро, столкнулся с проблемой по обработке таблиц. Есть большая таблица 480х480 ячеек и нужно сделать новую таблицу с размером 48х48 с помощью выбора каждой 10 ячейки и переноса в новую табличку. Сделать сам не могу, так как экселем особо не владею. Помогите пожалуйста!

cheshiki1


Роман Мусаев

Вот файлик. Может количество строк и столбцов немного не совпадает с написанным выше, но суть та же.
Извините за ссылку, но прикрепить не могу из-за большего объёма, чем можно  :)
http://yadi.sk/d/eiAWdfbX4mCwO

cheshiki1

в А1 и растягиваем =СМЕЩ(Лист1!$A$1;1+(СТРОКА()-1)*10;1+(СТОЛБЕЦ()-1)*10)

Mart222

#4
Чуть попроще вариант
=ИНДЕКС(Лист1!$A$1:$RK$481;СТРОКА()*10;СТОЛБЕЦ()*10)
Также в А1 и растягиваем

cheshiki1

на счет проще - это еще вопрос. с одним соглашусь что ф-цию СМЕЩ спецы не очень радуют.
в предложенной формуле идет по ячейкам 1,11,21,31,41 и т.д.
если делать как у вас (10,20,30,40) то так
=СМЕЩ(Лист1!$A$1;СТРОКА()*10;СТОЛБЕЦ()*10)

Mart222

Эксель хорош тем, что одну и ту же задачу можно решить несколькими путями.
Лично мне через ИНДЕКС както проще кажется чем через СМЕЩ, на подсознательном уровне )).
Вариант для 1, 11, 21 ... через ИНДЕКС.
=ИНДЕКС(Лист1!$A$1:$RK$481;СТРОКА()*10-9;СТОЛБЕЦ()*10-9)

Роман Мусаев