Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

сумма повторяющихся формул

Автор Олег Корзников, 20.05.2013, 21:33

« назад - далее »

Олег Корзников

Добрый день, уважаемые гуру
есть строка у ячейках которой может быть любое значение, в том числе и текстовое, но мне нужны значения типа 2/8,5 или 1/7 и т.д. Далее вычленить из этих значений то что стоит после "/" и просуммировать все ячейки в строке
как вычленить значение я вроде сообразил
=ЕСЛИ(ЕОШ(ПРАВСИМВ(E8;ДЛСТР(E8)-НАЙТИ("/";E8;1)));0;ПРАВСИМВ(E8;ДЛСТР(E8)-НАЙТИ("/";E8;1)))
может конечно и можно покороче но я не знаю
а вот как просуммировать вычленяя ряд (строку) из 40-50 ячеек незнаю
суммировать каждую ячейку получится больно длинная формула
может кто подскажет
ведь каждую ячейку надо обработать одинаково а потом просто просуммировать

                                       
NULL

Олег Корзников

Цитата: Serge 007 от 20.05.2013, 21:53
Олег Корзников, у Вас столько постов на форуме, а правила так и не прочитали...

ЗЫ СУММПРОИЗВ() поможет, читайте правила и получайте решение
Добрый день Сергей всяко пробовал, ну не понимаю я эту формулу
NULL

Poltava

А мы Вас не понимаем! Грех иметь 35 постов, а так и неудосужиться прочитать правила! особое внимание обратите на пункт 2! пока его не выполните Вам наврядли кто то поможет!
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Олег Корзников

Цитата: Poltava от 20.05.2013, 22:08
А мы Вас не понимаем! Грех иметь 35 постов, а так и неудосужиться прочитать правила! особое внимание обратите на пункт 2! пока его не выполните Вам наврядли кто то поможет!
Я конечно дико извиняюсь что не приложил файл
а правила я читал и суммпроизв по форуму искал
NULL

Poltava

Вводить как формулу массива
=СУММ(ЕСЛИ(ЕОШ(ПРАВСИМВ(A1:AE2;ДЛСТР(A1:AE2)-НАЙТИ("/";A1:AE2;1)));0;ПРАВСИМВ(A1:AE2;ДЛСТР(A1:AE2)-НАЙТИ("/";A1:AE2;1)))*1)
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Олег Корзников

Цитата: Poltava от 20.05.2013, 23:07
Вводить как формулу массива
=СУММ(ЕСЛИ(ЕОШ(ПРАВСИМВ(A1:AE2;ДЛСТР(A1:AE2)-НАЙТИ("/";A1:AE2;1)));0;ПРАВСИМВ(A1:AE2;ДЛСТР(A1:AE2)-НАЙТИ("/";A1:AE2;1)))*1)
Спасибо,очень помогли
а то массив очень большой
NULL

_Boroda_

Еще вариант
=СУММ(--ЕСЛИ(ЕЧИСЛО(ПОИСК("/";A1:AE1));ЗАМЕНИТЬ(A1:AE1;1;ПОИСК("/";A1:AE1);)))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995