Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Текстовые функции

Автор Vic Voodoo, 28.05.2013, 15:30

« назад - далее »

Vic Voodoo

Здравствуйте, знатоки!

В одной ячейке текст. В соседней ячейке число. Как сделать, чтобы в третьей ячейке появилось число из второй ячейки, если текст содержит слова "2 сорт", а если текст НЕ содержит "2 сорт", то появился бы 0 ?
Я думал, это легко, а вот провозился с функциями типа НАЙТИ или ПОИСК, но они нолик не ставят, а ставят #ЗНАЧ!
Помогите, пожалуйста, а то я в текстовых функциях не силен.

Vic Voodoo

Иными словами, есть ли функция, которая тупо выдаст например число взождений отрывка в текст? Входит он, выдас 1. Не входит, выдаст 0.

cheshiki1

=ЕСЛИ(ЕЧИСЛО(ПОИСК("2 сорт";A1));B1;0) как то так писал сразу на форум так что может какой аргумент упустил.

Vic Voodoo

Спасибо огромное! Видимо, это ЕЧИСЛО - не текстовая функция. А я искал в текстовых. Спасибо!

Serge 007

Цитата: Vic Voodoo от 28.05.2013, 15:39
ЕЧИСЛО() - не текстовая функция.
Нет, эта функция проверки свойств и значений. Её можно заменить на конструкцию НЕ(ЕОШ())
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390