Упрощение формулы

Автор Игорь Кожин, 08.06.2013, 12:22

« назад - далее »

Игорь Кожин

Возможно ли упростить вот эту формулу:
=ЕСЛИ(СОВПАД(A2;Лист2!A1);Лист2!C1;ЕСЛИ(СОВПАД(A2;Лист2!A2);Лист2!C2;ЕСЛИ(СОВПАД(A2;Лист2!A3);Лист2!C3;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A4);Лист2!C4;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A5);Лист2!C5;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A6);Лист2!C6;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A7);Лист2!C7;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A8);Лист2!C8;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A9);Лист2!C9;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A10);Лист2!C10;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A11);Лист2!C11;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A12);Лист2!C12;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A13);Лист2!C13;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A14);Лист2!C14;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A15);Лист2!C15;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A16);Лист2!C16;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A17);Лист2!C17;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A18);Лист2!C18;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A19);Лист2!C19;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A20);Лист2!C20;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A21);Лист2!C21;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A22);Лист2!C22;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A23);Лист2!C23;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A24);Лист2!C24;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A25);Лист2!C25;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A26);Лист2!C26;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A27);Лист2!C27;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A28);Лист2!C28;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A29);Лист2!C29;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A30);Лист2!C30;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A31);Лист2!C31;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A32);Лист2!C32;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A33);Лист2!C33;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A34);Лист2!C34;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A35);Лист2!C35;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A36);Лист2!C36;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A37);Лист2!C37;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A38);Лист2!C38;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A39);Лист2!C39;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A40);Лист2!C40;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A41);Лист2!C41;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A42);Лист2!C42;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A43);Лист2!C43;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A44);Лист2!C44;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A45);Лист2!C45;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A46);Лист2!C46;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A47);Лист2!C47;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A48);Лист2!C48;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A49);Лист2!C49;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A50);Лист2!C50;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A51);Лист2!C51;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A52);Лист2!C52;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A53);Лист2!C53;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A54);Лист2!C54;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A55);Лист2!C55;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A56);Лист2!C56;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A57);Лист2!C57;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A58);Лист2!C58;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A59);Лист2!C59;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A60);Лист2!C60;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A61);Лист2!C61;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A62);Лист2!C62;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A63);Лист2!C63;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A64);Лист2!C64;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A65);Лист2!C65;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A66);Лист2!C66;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A67);Лист2!C67;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A68);Лист2!C68;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A69);Лист2!C69;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A70);Лист2!C70;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A71);Лист2!C71;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A72);Лист2!C72;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A73);Лист2!C73;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A74);Лист2!C74;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A75);Лист2!C75;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A76);Лист2!C76;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A77);Лист2!C77;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A78);Лист2!C78;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A79);Лист2!C79;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A80);Лист2!C80;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A81);Лист2!C81;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A82);Лист2!C82;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A83);Лист2!C83;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A84);Лист2!C84;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A85);Лист2!C85;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A86);Лист2!C86;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A87);Лист2!C87;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A88);Лист2!C88;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A89);Лист2!C89;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A90);Лист2!C90;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A91);Лист2!C91;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A92);Лист2!C92;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A93);Лист2!C93;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A94);Лист2!C94;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A95);Лист2!C95;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A96);Лист2!C96;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A97);Лист2!C97;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A98);Лист2!C98;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A99);Лист2!C99;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A100);Лист2!C100;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A101);Лист2!C101;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A102);Лист2!C102;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A103);Лист2!C103;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A104);Лист2!C104;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A105);Лист2!C105;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A106);Лист2!C106;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A107);Лист2!C107;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A108);Лист2!C108;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A109);Лист2!C109;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A110);Лист2!C110;ЕСЛИ(СОВПАД(Основа!A2;Лист2!A111);Лист2!C111;))))))))))))))))))))))))))))))))))))))))))))))))))
Эта формула рабочая, вот только эксель выдает ошибку "Невозможно ввести указанную формулу, так как число уровней вложенности в ней превышает 64." Таблица прилагается.
Заранее спасибо.

cheshiki1


Игорь Кожин

Так легко :o :o :o Спасибо большое :D

edmar07

Возможно... ответ тот же что и в предыдущей теме... с проверкой пустых ячеек.
=ЕСЛИ(A4="";0;ВПР(A4;Лист2!A:C;3))