Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

По 2 исходным столбцам (размер и количество) преобразовать в 1 столбец

Автор Вячеслав Н., 11.06.2013, 13:21

« назад - далее »

Вячеслав Н.

Задача состоит в том, чтобы автоматом преобразовывать содержимое ячейки в столбец такое количество раз, сколько прописано в количестве. Просьба посмотреть скриншот.

sergo44441

Не торопись, и все успеешь намного быстрее

Serge 007

Была такая тема здесь
Несколько вариантов одной формулой (без доп столбцов) и вариант макросом
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390


edmar07

Цитата:  link=topic=9369.msg48323#msg48323 date=1370965905
Такой вариант с доп столбцом =ВПР(СТРОКА(H1);$A$2:$B$8;2;1)
Добрый день, sergo44441!

А если не трудно, можете объяснить как работает формула, я не совсем понял откуда берется количество повторений, формула вроде не ссылается на этот столбец.

Спасибо!
П.С.
все... разобрался, забыл за приблизительное значение )))))