Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

кол-во прерываний текстовой информации

Автор 0mega, 15.06.2013, 08:25

« назад - далее »

0mega

Доброго времени суток.
2003
sub no

есть столбец со смешанной (число и текст) информацией.
надо сосчитать ск. раз прерывалась текстовая информация
напр:
Тest
флаг
dog

34
7
,mnb
hgf

5
96,62
gh
чсм



Ввод текста прерывался 2 раза



Pelena

У меня так получилось
=СУММПРОИЗВ(ЕТЕКСТ(B2:B25)*ЕЧИСЛО(B3:B26))-ЕЧИСЛО(B25)

Sarytai


0mega

Елена, здравствуйте

Цитировать=СУММПРОИЗВ(ЕТЕКСТ(B2:B25)*ЕЧИСЛО(B3:B26))-ЕЧИСЛО(B25)
Я думал что это описка...
Если исправить на 25  - машина ругается ?!
Какую функцию выполняет пустая ячейка ?

Pelena

Здравствуйте.
Второй диапазон весь сдвинут на одну ячейку вниз В326. Таким образом сравниваются две ячейки, идущие подряд, и считается, сколько раз попадается сочетание текст-число

0mega