Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Вывод даты если Ячейка не пуста

Автор Максим Кабанин, 16.07.2013, 11:03

« назад - далее »

Максим Кабанин

Здравствуйте, Друзья.

Не могу разобраться, как реализовать такую штуку:

Нужно чтобы при при вводе данных в ячейку В2, в ячейке А2 появлялась сегодняшняя дата и время вида: 16.07.13 14.25, если данные не вводятся, то ячейка А2 остается пустой.

Причем чтобы данная дата оставалась неизменной допустим при сделующем открытии на следующий день.

Максим Кабанин

неужели никто не знает как это сделать? Реально ли это сделать формулами?

Serge 007

Нет, формулами - не реально

Макросом можно, но тогда нужно уточнить - если в В2 ввели какие-то данные и в А2 появилась дата и время, то что делать если в В2 ОПЯТЬ что-то ввели?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Poltava

Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Шпец Докапыч

Циклическая формула для однократной фиксации:
A2: =ЕСЛИ(ДЛСТР(A2)>1;A2;ЕСЛИ(B2<>"";ТЕКСТ(ТДАТА();"дд.ММ.гг чч:мм");""))
Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли

Максим Кабанин

Скажите пожалуйста как это использовать?

Шпец Докапыч

Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли

Wasilic

#7
Пример на VBA с проверкой на предмет изменения данных при повторной активизации ячейки.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.