Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Удалить символ c определенной позиции

Автор Ler44ikk, 17.08.2013, 20:29

« назад - далее »

Ler44ikk

Помогите пожалуйста, необходимо заменить или удалить значение 0 с определенной позиции (15) в строке, если она там есть, иначе оставить все как есть. (в виде формулы)
Как можно решить эту задачу?
например, есть такие значения:
44:44:0301149:0021
44:44:0201062:0532
44:44:0306028:0008
44:44:0303070:0502
44:44:0301115:0010
44:44:0000000:5502
44:44:0301173:0448



kuklp

Читаем правила и выкладываем пример в файле Эксель. Так же указываем, какое решение нужно - формулы, макрос и т.д.
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

Pelena

Вариант
=ЕСЛИ(ПСТР(A1;15;1)="0";ЛЕВСИМВ(A1;14)&ПРАВСИМВ(A1;3);A1)

Ler44ikk


DV68

Чуть короче :)
=ЗАМЕНИТЬ(A1;15;ПСТР(A1;15;1)="0";)

Ler44ikk


zs

=ЛЕВСИМВ(A5;14)&ПОДСТАВИТЬ(ПРАВСИМВ(A5;4);0;"";1)