Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Как добавлять сумму в ту же самую ячейку в зависимости от условия

Автор Sice, 18.08.2013, 06:41

« назад - далее »

Sice

Доброго времени суток ребята!
У меня есть ячейка, которая содержит сумму, а вернее баланс. Этот баланс считается в зависимости от выигрыша или проигрыша (либо возврата). Попомгите пожалуйста, как сделать условие, чтобы в зависимости от выигрыша (прибавлялась определенная сумма), от проигрыша (таже сумма отнималась) и от возврата (ничего не прибавлялось и не убавлялось) эта самая ячейка считала все?

Выглядит примерно так:
1) Баланс (сумма) 2) Проверяется диапозон столбцов (на выигрыш/проигрыш/возврат) 3) В зависимости от результата в этой же самой ячейки происходит расчет.

Сижу ломаю голову, получаются циклические формулы, считает один раз и все, если допустим подставить значение "проигрыш", то сумму эту уже не отнимает. Помогите пожалуйста разобраться.




Serge 007

Варианты:
1. Использование итераций
2. Использования макросов

В любом случае - читайте правила, выкладывайте файл
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

zs

IF Выигрыш TO СУММ+ ,IF Проигрыш TO СУММ- , FALSE СУММ
z.b. =ЕСЛИ(ПОИСКПОЗ("Выигрыш";$B$13:$D$13);СУММ($B$14:$D$14)+A14)