Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Рассчитать уникальные значения

Автор Leli4ka, 09.09.2013, 10:47

« назад - далее »

Leli4ka

Здравствуйте!
Помогите с формулой, необходимо подсчитать количество уникальных счетов, по которым произошли продажи за определенный год (2008)
Есть два файла, 1 - с номерами счетов, 2- с продажами по счетам

iron priest

сводная таблица

зачем таблица 1 так и не понял

cheshiki1

=СУММПРОИЗВ((A3:A9=[второй.xls]Лист1!$A$4:$A$10)*(ГОД([второй.xls]Лист1!$B$4:$B$10)=D2))
в D2 год.
как то так.

kuklp

Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

sergey-775

Доброго времени суток
В продолжение темы подскажите путь к решению следующей задачи (файл во вложении):
Данные:
В столбце А указаны даты (по возрастанию), но они повторяются, в столбце В - фамилии сотрудников, (фамилии тоже могут повторяться в пределах одной даты). Данные в столбцах А и В будут добавляться каждый день.
Условие:
В столбце G найти количество сотрудников за день (сейчас там данные, внесенные вручную); обязательное условие - не использовать макрос для подсчета, только стандартные формулы

DV68

=СУММПРОИЗВ(1/СЧЁТЕСЛИ(ИНДЕКС(B$2:B$16;ПОИСКПОЗ(F2;A$2:A$16;)):ИНДЕКС(B$2:B$16;ПОИСКПОЗ(F2;A$2:A$16));ИНДЕКС(B$2:B$16;ПОИСКПОЗ(F2;A$2:A$16;)):ИНДЕКС(B$2:B$16;ПОИСКПОЗ(F2;A$2:A$16))))

_Boroda_

Еще вариант
=СУММПРОИЗВ((A$2:A$16=F2)*(ПОИСКПОЗ(A$2:A$16&B$2:B$16;A$2:A$16&B$2:B$16;)=СТРОКА(A$1:A$15)))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

zs

#7
Альтернативный матричный вариант. С уважением, ZS.
P.S. Меньше вычислений-больше данных.

sergey-775

 DV68,  _Boroda_,

Премного благодарен, то что надо

sergey-775

Цитата: zs от 16.09.2013, 17:33
Альтернативный матричный вариант. С уважением, ZS.
P.S. Меньше вычислений-больше данных.
А вот это действительно интересный подход, спасибо