Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Как объединить две функции ЕСЛИ

Автор AlexKK, 16.09.2013, 14:48

« назад - далее »

AlexKK

=ЕСЛИ(A10="";"";"з")
=ЕСЛИ(A10="работа";"р";"")

cheshiki1

=ЕСЛИ(A10="работа";"р";ЕСЛИ(A10="";"";"з"))

AlexKK

Что-то не получается. 1ЕСЛИ отвечает условию если в столбце А есть текст тогда з, если пробел то пусто. 2ЕСЛИ если в столбце А появляется слово работа тогда р.

cheshiki1


AlexKK

Большое спасибо. 3 часа мучился.

zs

Не объединять, ЕСЛИ можно использовать 1 функцию
=ЕСЛИ(ИЛИ(ЛЕВСИМВ(A1)="р";ЕПУСТО(A1));ЛЕВСИМВ(A1);ЗАМЕНИТЬ(ЛЕВСИМВ(A1);1;1;"З"))

AlexKK

Цитата: cheshiki1 от 16.09.2013, 15:30
смотрите
=ЕСЛИ(A7="работа";"р";ЕСЛИ(A7="";"";"з")) А как можно добавить еще одно условие например работа тогда р и услуги тоже р. т.е добавить к работе еще услуги

AlexKK

Разобрался =ЕСЛИ(ИЛИ(A7="работа";Ф7="услуги")"р";ЕСЛИ(A7="";"";"з"))

zs

=ЕСЛИ(ИЛИ(ЛЕВСИМВ(A4)="р";ЛЕВСИМВ(A4)="у";ЕПУСТО(A4));ПОДСТАВИТЬ(ЛЕВСИМВ(A4;1);"у";"р";1);ЗАМЕНИТЬ(ЛЕВСИМВ(A4);1;1;"З"))

cheshiki1

zs не удачно.  ;)
если там будет слово рубанок или удача или еще какое начинающееся с р или у. Да и длинная формула получилась у вас.

zs

Здравствуйте, cheshiki1!
=ЕСЛИ(ИЛИ(A4="работа";A4="услуги";ЕПУСТО(A4));ПОДСТАВИТЬ(ЛЕВСИМВ(A4;1);"у";"р";1);ЗАМЕНИТЬ(ЛЕВСИМВ(A4);1;1;"З"))
С уважением, ZS(5)
P.S. И в формулах прямая короче ломанной. И в данных организация и универсальность.