Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

как создать условие (формулу)

Автор evgens, 11.10.2013, 12:21

« назад - далее »

evgens

Добры день всем... подскажите как выпонить ряд условий одним махом... Нужно если значение в ячейке A1 находится в интервале от 0 до 1, то в ячейке B2 значение 0;   если значение в ячейке A1 находится в интервале от 1 до 1000, то в ячейке B2 значение 70+2%;   а вот если значение в ячейке A1 находится в интервале от 1001 и выше, то в ячейке B2 значение 75+3% вот както так надо это выпонить

NooBasTiK

По крестьянски как то вот так:
=ЕСЛИ(И(A1>0;A1<1);0;ЕСЛИ(И(A1<=1000;A1>=1);71,4;77,25))

evgens


Czeslaw

У меня вышла формула немного короче, только не пойму почему 70+2%, или 70 это не проценты.
=IF(A1<=1;0;IF(AND(A1>1;A1<=1000);72%;IF(A1>1000;78%)))
=IF(A1<=1;0;IF(AND(A1>1;A1<=1000);71,4;IF(A1>1000;77,25)))

cheshiki1


evgens

70 это постоянная величина а вот прибавляются потом проценты

evgens

величина 70 получается если значение от 1 до 1000 и плюс 2% и если величина больше чем 1001 тогда 75 плюс 3%

zs

{0;1;1001}
=ЕСЛИ(A1-1000>=1;77,25;ЕСЛИ(И(A1-1000<=1;A1>=1);71,4;0))
Respectfully yours, ZS

evgens

РЕБЯТА СПАСИБО ВСЕМ ЗА ПОМОЩЬ, ТЕПЕРЬ ВСЕ КАК НАДО