Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Помогите с формулой

Автор evergrey, 20.10.2013, 16:10

« назад - далее »

evergrey

День добрый, знатоки и гуру!!!
Нужна формула подсчета:
Просуммировать ячейки C$1:C15,
Отнять ячейку J15,
если ВСЕ данные из ячеек D1-D15 >0,
то результат вывести в ячейку К15,
если хотя бы в одной ячейке столбца D < 0, подсчет не производить, либо вывести 0.

Poltava

ЦитироватьНужна формула подсчета
Задача решаемая причем весьма просто НО нам нужен файл примера рисовать за вас ваши таблички никто не горит желанием.
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

iron priest

я думаю здесь без примера можно

=ЕСЛИ(МИН(D:D)<0;"";СУММ(C3:C71)-J71)

на будущее автору темы - делайте файл-пример

evergrey

А как сделать чтобы если одна из ячеек столбца D была пустая (не 0, а именно пустая),
то результат в ячейке К15 не выводился, либо был равен 0?
Заранее спасибо!!!

zs

=ЕСЛИ(ИЛИ(МИН(D:D)=0;СЧИТАТЬПУСТОТЫ(D1:ИНДЕКС(D1:D17;ПОИСКПОЗ(МАКС(A1:A15);A1:A17)))>0);"";СУММ(C1:C17)-J17)

evergrey

Спасибо всем, с вашей помощью нашел решение:
=ЕСЛИ(ИЛИ(МИН(D:D)=0;СЧИТАТЬПУСТОТЫ(D$1:ИНДЕКС(D$1:D17;))>0);"";СУММ(C$1:C17)-J17)

zs

evergrey. Если больше 17 заполнено (не D:D), необходимо ориентироваться по датам ПОИСКПОЗ(МАКС) Иначе пустот >