Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Помогите, пжл, с функцией SUMPRODUCT

Автор snupy86, 23.10.2013, 11:07

« назад - далее »

snupy86

Знатоки, добрый день.
Помогите пжл, с функцией SUMPRODUCT. Как получить промежуточные итоги.

Есть 3 столбца, SUMPRODUCT я получаю =SUMPRODUCT(D1:D7;E1:E7) значение 32833,38. Вопрос: а как получить промежуточное значение, если отфильтровать по первому столбцу, например (по CPT), чтобы значение пересчиталось. Очень надо, спасибо.

EXW   2160,25   4
CPT   518,6           5
CPT   267,64   6
CPT   212,88   7
FOB   836,36   9
FOB   174,64   7
CPT   1083,74   9

cheshiki1

проще всего это перемножить построчно в отдельном столбце и по этому столбцу использовать =ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;F2:F9)

snupy86

Цитата: cheshiki1 от 23.10.2013, 11:45
проще всего это перемножить построчно в отдельном столбце и по этому столбцу использовать =ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;F2:F9)

Я так думал, но не совсем удобно будет. У меня отчет выгружается из системы и итоги подсчитываются SUMPRODUCT, а таких итоговых столбцов 9, т.е. мне еще надо добавить перемноженных 9 столбцов, а потом использовать subtotal, что не очень удобно.

Т.е. в  excel нет функции типа SUMPRODUCT, наподобие subtotal?


Serge 007

Цитата: snupy86 от 23.10.2013, 12:04в  excel нет функции типа SUMPRODUCT, наподобие subtotal?
Эту функцию выполняет сводная таблица
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

snupy86

Цитата: _Boroda_ от 23.10.2013, 12:42
Кладите свою таблицу. Напишем Вам формулу

Выкладываю файл, спасибо.

Если фильтровать столбцы С,E или G, чтобы менялись значения в строке 10 стол.  К:AC


_Boroda_

=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(A10;СТРОКА(A11:A17)-СТРОКА(A10);))*J11:J17*K11:K17)/J10
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

snupy86

Цитата: _Boroda_ от 23.10.2013, 14:59
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(A10;СТРОКА(A11:A17)-СТРОКА(A10);))*J11:J17*K11:K17)/J10


Спасибо, огромное!!! Все получилось!!!