Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Формула расчета стоимости

Автор brudiq, 29.11.2013, 10:54

« назад - далее »

brudiq

Добрый день, необходимо написать формулу для расчета стоимости.
Все условия указаны в приложенном файле.
Буду признателен за помощь!

cheshiki1

=C2*(1+ВПР($B2;$I$4:$N$8;ПРОСМОТР($C2;ПСТР($J$3:$N$3;1;ПОИСК("-";$J$3:$N$3)-1)+0,1;СТОЛБЕЦ($A$1:$E$1))+1;0))
только >2000 замените на 2000-...
и В у вас в одном месте английская а в другом русская - сделайте одинаковые.

Czeslaw

Можно использовать и такие формулы:
=C2*(1+VLOOKUP($B2;$I$4:$N$8;LOOKUP(C2;{0;100;500;1000;2000};{"2";"3";"4";"5";"6"});0))
=C2*(1+INDEX($I$4:$N$8;MATCH(B2;$I$4:$I$8;0);LOOKUP(C2;{0;100;500;1000;2000};{"2";"3";"4";"5";"6"})))

zs

=ЕСЛИ(C3>2000;ИНДЕКС($I$4:$N$8;ПОИСКПОЗ(B3;$I$4:$I$8;0);6);ЕСЛИ(C3>1000;ИНДЕКС($I$4:$N$8;ПОИСКПОЗ(B3;$I$4:$I$8;0);5);ЕСЛИ(C3>500;ИНДЕКС($I$4:$N$8;ПОИСКПОЗ(B3;$I$4:$I$8;0);4);ЕСЛИ(C3>100;ИНДЕКС($I$4:$N$8;ПОИСКПОЗ(B3;$I$4:$I$8;0);3);ЕСЛИ(C3<100;ИНДЕКС($I$4:$N$8;ПОИСКПОЗ(B3;$I$4:$I$8;0);2))))))*C3+C3

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390