поиск ближайшего значения в строке

Автор president, 30.11.2013, 14:25

« назад - далее »

president

Помогите пожалуйста вот с такой задачей:
Необходимо найти самое близкое по значению число в строке данных (см.вложенный файл)

За ранее спасибо!

zs

Здравствуйте, president
=НАИБОЛЬШИЙ(A5:I5;9-СЧЁТЕСЛИ(A5:I5;"<"&A5))
С уважением,ZS5)
P.S. Если пригодиться-не забывай отблагодарить

president

#2
Что-то не то получилось, я видимо неверно объяснил.
Необходимо найти самую наименьшую разницу к числам в столбце "А"
Пример: Ячейка "А4" число: 63,586 какое число всех ближе из ячеек: "C4"D4"E4"F4"G4"H4"I4" к числу из нашей ячейки "А4". Способ вычисления: =ABS(A4-C4);=ABS(A4-D4); =ABS(A4-E4);=ABS(A4-F4);=ABS(A4-G4);=ABS(A4-H4);=ABS(A4-I4); Если произвести вычисления, то получим: 48,351; 0,649; 15,000; 40,018; 28,350; 725,649;   4,870; наименьшее число это 0,649 т.е. ближайшее число к 63,586 (ячейка "А4") это число из ячейки "D4" 64,235 и это число пишем и т.д. построчно.

За ранее  спасибо!

я сделал вот так: =МИНА(ABS(A4-C4);ABS(A4-D4);ABS(A4-E4);ABS(A4-F4);ABS(A4-G4);ABS(A4-H4);ABS(A4-I4);) но он почему то вычисляет нули, и формула уж совсем примитивная...

Serge 007

формула массива:
=ИНДЕКС(C4:I4;;ПОИСКПОЗ(МИН(ABS(A4-C4:I4));ABS(A4-C4:I4);))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

president

Serge 007 спасибо огромное, но вот совсем забыл, необходимо еще чтоб номер столбца указывал где у нас обнаружено нужное число.

За ранее спасибо!

zs

=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(МИН(ABS(C1-A1);ABS(D1-A1);ABS(E1-A1);ABS(F1-A1);ABS(G1-A1);ABS(H1-A1);ABS(I1-A1))+A1;C1:H1;0));A1-МИН(ABS(C1-A1);ABS(D1-A1);ABS(E1-A1);ABS(F1-A1);ABS(G1-A1);ABS(H1-A1);ABS(I1-A1));МИН(ABS(C1-A1);ABS(D1-A1);ABS(E1-A1);ABS(F1-A1);ABS(G1-A1);ABS(H1-A1);ABS(I1-A1))+A1)

president

спасибо, а вот как быть с номером столбца, т.е. с лева на право условно нумерация столбцов чтоб начиналась со столбца, в моем примере, "В" это 1, "С" это 2, D это 3 и т.д.
вот мы нашли ближайшее число в ячейке "D4" пишем его значение, а так же находим номер столбца в нашем случае "3".

За ранее спасибо!!!

zs

#7
=ПОИСКПОЗ(J1;B1:I1;0)
P.S. заранее, слева, направо.. наречие.. пишется слитно! справки в интернет

president

 :'( каюсь, безграмотный, исправлюсь, хороший ресурс, ликбез и по екселю и по русскому языку  :)

Спасибо!