Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Счёт среднего по части значения ячейки

Автор Shadowmaker, 09.12.2013, 17:12

« назад - далее »

Shadowmaker

Подскажите, возможно ли без использования макросов реализовать следующее:
Есть столбец с данными, где каждая ячейка имеет значение в маске xx/yy/zz
Необходимо получить среднее по xx, yy, zz и вывести значение в этой же маске в отдельной ячейке.

Выглядит примерно так:
10/0/11
2/1/13
8/4/5

TimSha

Цитата: Shadowmaker от 09.12.2013, 17:12
Подскажите, возможно ли без использования макросов...
Да. Разогнать по столбам, пересчитать, собрать до кучи. Как вариант.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

iron priest


cheshiki1

=ОКРУГЛ(СРЗНАЧ(--ЛЕВСИМВ(A1:A3;ПОИСК("/";A1:A3)-1));2)&"/"&ОКРУГЛ(СРЗНАЧ(--ПСТР(A1:A3;ПОИСК("/";A1:A3)+1;ПОИСК("/";A1:A3;ПОИСК("/";A1:A3)+1)-ПОИСК("/";A1:A3)-1));2)&"/"&ОКРУГЛ(СРЗНАЧ(--ПСТР(A1:A3;ПОИСК("/";A1:A3;ПОИСК("/";A1:A3)+1)+1;99));2)
формула массива.

Shadowmaker

Не получается...
Попробовал вписать эту формулу, ввёл как формулу массива и всё равно получил #ЗНАЧ!

Выложить сам файл к сожалению не могу - нет такой технической возможности

Какие могут быть затыки с формулой...

Я её кстати не до конца понял... можно ли поэтапно расписать что и где вычисляется?

cheshiki1


zs

Здравствуйте, Shadowmaker. Вы пишите: "...каждая ячейка имеет значение в маске xx/yy/zz",
тогда
=(ЛЕВСИМВ(E1;2)+ЛЕВСИМВ(E2;2)+ЛЕВСИМВ(E3;2))/(СТРОКА()-1)&"/"&(Ч(--ПРАВСИМВ(ЛЕВСИМВ(E2;5);2))+Ч(--ПРАВСИМВ(ЛЕВСИМВ(E1;5);2))+Ч(--ПРАВСИМВ(ЛЕВСИМВ(E3;5);2)))/(СТРОКА())&"/"&(ПРАВСИМВ(E1;2)+ПРАВСИМВ(E2;2)+ПРАВСИМВ(E3;2))/(СТРОКА()-1)

Shadowmaker

Спасибо огромное! Разобрался!

ЗЫ: #знач! писался потому что часть значений при выгрузке из базы была не определена и имела вид "//" добавил проверку и всё заработало