Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Макрос, позволяющий подсвечивать значения на поле данных

Автор Smarty_kazan, 20.12.2013, 19:33

« назад - далее »

Smarty_kazan

Добрый день, господа.
Помогите пожалуйста сделать так чтобы на поле 10х10, нажимая на одну клетку высвечивались клетки, которые соответствуют данной ячейке из базы данных. Файл прилагаю. Заранее благодарю и рассчитываю на Вашу помощь.

kuklp

Ничего не понял. Стрелки в примере ведут в чисто поле... Допустим нажали ячейку Е7. Что должно произойти и почему?
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

Smarty_kazan

например нажимая поле 2.2 (красная). должны высвечиваться ячейки которые находятся в "базе", то есть желтые.
Извините, пытался как мог объяснить.

Smarty_kazan


kuklp

Это не ответ на мой вопрос:
Цитата: KuklP от 20.12.2013, 20:11
...нажали ячейку Е7. Что должно произойти и почему?
Еще вопрос: почему в первом примере выделена ячейка J10? По какой логике?
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

kuklp

#5
Может так надо?
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

Smarty_kazan

Спасибо огромное. Именно то, что и надо было. Только еще одна просьба, простите за "нубство". Как посмотреть сами строки, чтобы была возможность менять области в базе.
Спасмбо еще раз.

Smarty_kazan


Smarty_kazan

Уважаемый KuklP, помогите пожалуйста.как сделать чтобы на желтых ячейках выходило число повторений. То есть либо одно повторение, либо два и т.д. пробовал с помощью формулы =ЕСЛИ(СЧЁТЕСЛИ(B$1:B2;B2)=1;МАКС(A$1:A1)+1;"") попробовать сделать нумировку.Не получилось. Заранее спасибо.

kuklp

Smarty_kazan, обращаясь ко мне персонально, Вы тем самым сознательно сужаете круг потенциальных помощников. Обращайтесь к форуму, это может сильно ускорить получение ответа.
По теме - о каких повторениях речь?
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

Smarty_kazan

Учту.Спасибо.Просто откликнулись только Вы.
Хотелось бы для удобства видеть сколько раз повторяется значение.
Например: во всей базе для значения 1-1(красная ячейка) соответствует несколько значений 10-10(желтая ячейка), и они идут не подряд.
Вот и интересно как сделать так, чтобы автоматом находил и нумеровал повторения, а затем выносил на само поле, с подписью на желтой ячейке. Например цифра 3 или любая другая.
Таким образом узнается наиболее вероятное распределение не только по количеству самих ячеек, а также по их повторению.

kuklp

Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

Smarty_kazan

Да! Огромное спасибо Вам! Постоянно выручаете.