Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Индекс Поискпоз

Автор usar, 04.02.2014, 00:26

« назад - далее »

usar

Добрый вечер, прошу помощи в формуле.
Лист2, при выборе значений из списка (ячейка B3), значения в раздельных формулах выводятся корректно, а если совместить, то выдает #Н/Д.

cheshiki1

опишите суть задачи. поищем формулы по короче чем у вас.

usar

при выборе значения из списка выводить в ячейке результат, который на листе настройка. но, так же есть формула которая работает от даты, и для разных месяцев, свои значения.

DV68

Можно так:
=ЕСЛИ(ЕНД(ПОИСКПОЗ(B3;Настройки!A3:A18;0));
ИНДЕКС(Настройки!E9:H18;ПОИСКПОЗ(B3;Настройки!D9:D18;0);ПОИСКПОЗ(РАЗНДАТ(E4;H1;"m");{0:4:7:13}));
ТЕКСТ(ИНДЕКС(Настройки!B3:B18;ПОИСКПОЗ(B3;Настройки!A3:A18;0));
ВЫБОР(ПОИСКПОЗ(ИНДЕКС(Настройки!B3:B18;ПОИСКПОЗ(B3;Настройки!A3:A18;0));{1:99998:99999});"0%";"#";"# ##")))

usar

Цитата: DV68 от 04.02.2014, 14:31
Можно так:
=ЕСЛИ(ЕНД(ПОИСКПОЗ(B3;Настройки!A3:A18;0));
ИНДЕКС(Настройки!E9:H18;ПОИСКПОЗ(B3;Настройки!D9:D18;0);ПОИСКПОЗ(РАЗНДАТ(E4;H1;"m");{0:4:7:13}));
ТЕКСТ(ИНДЕКС(Настройки!B3:B18;ПОИСКПОЗ(B3;Настройки!A3:A18;0));
ВЫБОР(ПОИСКПОЗ(ИНДЕКС(Настройки!B3:B18;ПОИСКПОЗ(B3;Настройки!A3:A18;0));{1:99998:99999});"0%";"#";"# ##")))

спасибо огромное!