Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Перестает работать формула при замене данных в одной из ячеек

Автор VladK, 07.02.2014, 00:16

« назад - далее »

VladK

Здравствуйте!

Имеется простое действие:

На листе1
ячейка1=артикул (например, "10502850")
ячейка2=формула с функцией ВПР, которая берет значение артикула из ячейки1 и подбирает цену из листа2

На листе2
ячека1=артикул (например, "10502850")
яцейка2=цена

При копировании на лист2 в ячейку1 такого же артикула, формула на первом листе перестает работать.

Формат ячейки с артикулом на первом листе:текстовый
Формат ячейки с артикулом на втором листе:общий. При замене на текстовый ничего не меняется, пока не прокликаешь ячейку (появляется зеленый треугольник)

Если добавить во все ячейки апостроф перед артикулом он видим (формула не работает), пока не кликнуть по ячейке (тогда все ОК)

Вопрос: Почему не работает формула, если я копирую только значения? Как протянуть зеленый треугольник по всем ячейкам=сделать каждую ячейку прокликанной? Или есть другие варианты?


Извините за форму изложения, мозг взорвался.

Спасибо откликнувшимся!

gling

Про зеленые треугольники. Попробуйте это.
Public Sub w1C_convert1() 'преобразование текста в число
    ActiveSheet.UsedRange.FormulaLocal = ActiveSheet.UsedRange.FormulaLocal
End Sub
mail: vovik100661@gmail.com;
ЯД-41001506838083.

cheshiki1


VladK

Во вложении смоделированный пример. Если на листе2 артикул из ячейки I1 скопировать в ячейку B1, то формула на листе1 не работает. Если прокликать по ячейке, в которую мы скопировали новый артикул, то "вуаля", все работает.

gling

Была и есть такая же канитель при выгрузки данных из другой программы. Сделал при обработке дополнительный столбец с формулой =ЗНАЧЕН() и стал ссылаться на этот столбец. Может и Вам таким образом выйти из этой заморочки.
mail: vovik100661@gmail.com;
ЯД-41001506838083.

VladK

Не подошло. ВПР ищет совпадения с артикулом в текстовом формате.

Сейчас находит артикул (формат ячейки - общий), но если два раза кликнуть по этой ячейке, то формула перестает работать.

Если я меняю формат искомого артикула на текстовый-не работает, а если кликнуть два раза, то все ОК. Получается нужно сделать весь столбец прокликанным.

Я как-то боролся с этим вопросом давно и помню, что фишка была в умножении столбца на что-то (может быть на единицу).

Не понятно почему такое происходит.

iron priest

Цитата: VladK от 12.02.2014, 17:23
Не подошло. ВПР ищет совпадения с артикулом в текстовом формате.

Сейчас находит артикул (формат ячейки - общий), но если два раза кликнуть по этой ячейке, то формула перестает работать.

Если я меняю формат искомого артикула на текстовый-не работает, а если кликнуть два раза, то все ОК. Получается нужно сделать весь столбец прокликанным.

Я как-то боролся с этим вопросом давно и помню, что фишка была в умножении столбца на что-то (может быть на единицу).

Не понятно почему такое происходит.

текст по столбцам в помощь

VladK

Наконец-то! Три дня голову ломал. Скиньте в личку электронный кошелек (qiwi,ЯД,webmoney), обязан отблагодарить.
Большое спасибо!

Prist

Вполне понятно почему такое происходит. Проблема не нова.
ВПР ищет данные бинарным поиском без приведения типов, а значит отличает текст от чисел. Текст "1" будет иметь отличный бинарный код от числа 1 и как следствие не будет считаться совпадением.
Если ищете в диапазоне с числами, то приводите внутри формулы значения к числовому формату:
=ВПР(--A1;B1:C10;2;0)
Так же можно в обеих таблицах для верности привести формат к числовому виду:
-копируете любую пустую ячейку;
-выделяете диапазон с "числами";
-Правая кнопка мыши-Специальная вставка-Сложить.
Все числа станут числами и все будет работать.

В случае с текстом несколько хуже. Но можно применить формулу массива:
=ВПР(ТЕКСТ(A1;"");ТЕКСТ(B1:C10;"");2;0)
формула массива вводится в ячейку одновременным нажатием трех клавиш: Ctrl+Shift+Enter.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
www.excel-vba.ru
Просто СПАСИБО [+оказать+]
Считаешь СПАСИБО мало? Яндекс.Деньги: 41001332272872; WM: R298726502453

iron priest

Цитата: VladK от 12.02.2014, 20:36
Наконец-то! Три дня голову ломал. Скиньте в личку электронный кошелек (qiwi,ЯД,webmoney), обязан отблагодарить.
Большое спасибо!

Пожалуйста. но данная помощь не стоит денег=)